Graz im #lockdown – auf den Spuren von Kangbashi

Grosse Dateien mit SMASH gratis versenden…

Heute bin ich im Blog von Gunther Wegner auf einen interessanten neuen Dienst gestoßen, der die einfache Dateiübertragung von beliebig großen Dateien via email und Downloadlink ermöglicht – gratis, ohne Werbung und mit einer Speicherdauer von maximal 7 Tagen. Hier der Link zum Originalartikel:
http://gwegner.de/blog/fromsmash-com-grosse-dateien-uebertragen-leicht-gemacht/

Aber nicht vergessen, sensible Daten vor dem Versand zu verschlüsseln – man weiß ja nie, wer mitliest!

Das PC-Upgrade 2017 – Teil 2

Wie im letzten Artikel beschrieben verlief bei der Erneuerung der Hauptbestandteile meines Arbeitsplatz-Workhorses alles glatt – bis auf die Probleme mit der m.2 SSD von Samsung, die nach einem Warmstart nicht mehr erkannt wurde.

Ich ignorierte das Problem erstmal und lies ein paar Vergleichstests laufen, um mir ein Bild über den zu erwartenden Geschwindigkeitsboost mit der m.2-SSD  zu machen – die technischen Daten lasen sich ja vielversprechendend (…bis zu 3.200MB/s sequentielle Lese und 1.900MB/s Schreibgeschwindigkeit…). Also – schaumamal:

Beginnen wir mit einer relativ schnellen Western Digital-Festplatte mit 4 GB – da sehen die Werte so aus:

Mit einer handelsüblichen, durchschnittlichen SSD von Samsung mit 1 TB um ca. 350 Euro wird die Sache schon etwas flotter – im Vergleich zu den alten SCSI- (oder PATA, Gott behüte!) Zeiten allerdings schon wahnsinnig schnell:

So gesehen ist der Speed einer direkt an den PCI-Express-Bus gehängten m.2-SSD mit 1 TB abnormal – die gute Samsung 960 Evo hält tatsächlich, was sie verspricht:

Kaum zu glauben, dass dieses kleine Kärtchen soviel Dampf machen kann!

Das alles hilft aber natürlich gar nichts, wenn die Platte nach jedem Warmstart nicht mehr im System auftaucht – also ab in die Support-Warteschlange.

Ich schilderte (etwa am 10.1.) das Problem dem Asus Support und erhielt nach relativ kurzer Zeit (2 Tage!) und in weiterer Folge freundliche, obgleich wenig hilfreiche Antworten und Tipps, z.B. einen BIOS-Reset durchzuführen, das Quickboot-Menü zu deaktivieren oder die POST-timeout zu erhöhen. Ich probierte brav alles durch, obwohl es nichts brachte – nur den Rat, auf eine ältere BIOS-Version downzugraden, ignorierte ich:

Bitte setzen Sie einmal das BIOS hardwarenah zurück. Schalten Sie dazu bitte das Netzteil aus und entnehmen Sie die CMOS-Batterie. Setzen Sie diese dann andersherum wieder ein, und warten Sie mindestens fünfzehn  Minuten. Danach setzten Sie die Batterie richtigherum wieder ein und schalten das Netzteil wieder ein. Stellen Sie dann im BIOS die Standardeinstellungen wieder her (Taste F5) und speichern diese ab. Wenn Sie z.B. ein RAID eingerichtet haben, stellen Sie den entsprechenden SATA-Controller bitte wieder auf RAID. Testen Sie dann bitte, ob das von Ihnen beschriebene Verhalten noch auftritt.

Bitte stellen Sie einmal im BIOS die Post delay Time etwas höher. Evtl. benötigt die m.2 beim Reset eine längere Initialisierungszeit durch das neue BIOS. Haben Sie schon einmal ein Downgrade auf eine frühere BIOS Version versucht?

Ich lies die Sache also auf sich beruhen und ärgerte mich in der Zwischenzeit mit meinem neuen 32-Zöller herum – ärgern ist vielleicht etwas übertrieben, aber wenn man sich auf einen neuen Riesenmonitor mit hoher Auflösung (Philips Philips BDM3270QP) freut und dieser in einer beschädigten Verpackung und ohne jegliches Zubehör, ja nicht einmal mit einem Standfuß, geliefert wird, kann einem die Vorfreude schon vergehen. Ich bin aber andererseits froh darüber, denn umgehend zurückgesandt entdeckte ich ebenfalls beim großen Versandhaus den BenQ BL3201PT mit echter UHD-Auflösung (3840 X 2160 Pixel) und – den Rezensionen nach – sehr guter Eignung als CAD- oder Fotobearbeitungsmonitor. Er deckt den den kompletten sRGB-Farbraum ab, also das, was üblicherweise im Internet verbreitet wird – ich maße mir nicht an, bei normalen Fotomotiven den Unterschied zwischen sRGB und AdobeRGB unterscheiden zu können, also reicht das für meine Zwecke vollkommen aus. Der BenQ war einige Tage später schon im Haus und nach kurzer Aufwärmzeit ging´s an´s Auspacken und Aufstellen. Zum Glück ist mein Schreibtisch groß genug – so ein 32-Zöller hat schon ordentliche Ausmaße! Allerdings war natürlich das Anschlußkabel zu kurz, also ein längeres HDMI-Kabel gecheckt, kann losgehen…aha, kein Bild. Neu booten. Windows-Logo, dann kein Bild. Auflösungstechnisch kann´s kein Problem sein, meine Radeon R9-Grafikkarte packt die Pixelanzahl locker. Also ab in´s Bildschirmmenü (ui, der hat sogar eine Kabel-Fernbedienung, die an eine USB-Schnittstelle gesteckt wird!) und ein paar Einstellungen bzw. Eingangsvarianten durchgeklickt – siehe da, ein Bild, in voller Pracht!

Wenn man von 1920 x 1200  auf 3840 X 2160 Pixel umsteigt, glaubt man, man hätte vorher in einen alten portablen Röhrenfernseher geglotzt (auch wenn EIZO draufsteht) – beeindruckend! Beeindruckend allerdings auch, was Windows 10 und sogar die Adobe Creative Suite mit dem überbordenden Pixelangebot machen, denn da gibt es einige Finetunings, mit denen man Stunden verbringen kann. Besonders ärgerlich ist zB, dass diverse Windows-Systemmenüs (IMMER!!!) noch nicht korrekt skaliert werden und dass zB Photoshop und Indesign ihre Einstellungen für die Bildschirmskalierung an unterschiedlicher Stelle anbieten – such, lieber User, such! In Adobe Lightroom habe ich dann wiederum keine Möglichkeit für eine vergrößerte Bildschirmdarstellung gefunden – also doch die Lesebrille aufsetzen.

Ziemlich ärgerlich wird die Sache allerdings wenn man (so wie ich 😉 zusätzlich noch einen zweiten Monitor mit 1920×1200 Pixel an das System dranhängt – dann kommt sich nämlich die Fenster-/Symbolskalierung von Windows gegenseitig in´s Gehege und man hat entweder eine Mini-Fuzzi-Zwergerl-Anzeige am kleineren Monitor oder eine zu große Darstellung am großen Bildschirm…hin und her, wie man´s auch dreht und wendet, es wird nix mit der perfekt im Zweitmonitor dargestellten virtuellen Maschine (ja, mein altes XP lebt auch noch), irgend etwas sieht einfach immer Scheisse aus.

Als ich dann diverse Remote-Desktop-Verbindungen zu unseren Servern ausprobiere kommt mir die erlösende Idee: Warum nicht die alte XP-Maschine in ihrem VMware-Player „versteckt“ laufen lassen und via Remote-Desktop am Zweitschirm darstellen – die Performance reicht ja locker aus. Und siehe da, das gute RDP-Programm liefert ein perfekt auf 1920×1200 skaliertes Bild meiner (virtuellen) XP-Maschine, alles ist gut:

Am Tag darauf kommt auch die (scheinbar) erlösende Antwort vom ASUS-Support: Es gibt ein neues Firmware-Update für die m.2 SSD, mit dem das Problem des „Verschwindens“ behoben sein soll(te). Allerdings musste ich noch zwei Tage auf das Erscheinen dieses Updates warten – Samsung hatte einmal arge Probleme mit einem vorschnell veröffentlichten Firmware-Update einer Festplatte und liefert seitdem die Updates nur mehr verzögert aus. Wahrscheinlich hoffen sie, dass sich ein paar User prompt melden, sollten die Daten ihrer SSD beim Update den Gang in´s Nirwana angetreten haben. Erschreckende Vorstellung…bei den gängigen Sicherungsgepflogenheiten unbedarfter Anwender!

To be continued a.s.a.p.!

 

Das PC-Upgrade 2017: Zwei kleine Wunder ;-)

Workstation 2017 mit Asus X99-AII und Samsung EVO 960 M.2 SSD mit 1 TB (grünes Rechteck)

Gestern habe ich mein „Arbeitspferd“ auf den aktuellen Stand der Technik gebracht – und es geschah ein kleines Wunder:
Alles funktionierte auf Anhieb.

Heute habe ich noch das BIOS des Motherboards auf den aktuellen Stand gebracht – und es geschah wieder ein kleines Wunder:
Seitdem wird die pfeilschnelle und sauteure 1 TB Samsung M.2-SSD nicht mehr erkannt.

Aber wen wundert so etwas schon, wenn er nur ausreichend lange IT-Erfahrung vorweisen kann?

 

Hardware-Aufstellung mit aktuellen Preisen (Stand 12/2016)


  • Samsung MZ-V6E1T0BW SSD 960 Evo NVMe M.2 1 TB: € 439,00
  • INTEL Core i7-6800K 3,40GHz LGA2011-V3 15MB Cache Boxed CPU: € 452,70
  • Asus X99-A II Mainboard (Sockel 2011-v3, ATX, Intel X99, 8x DDR4-Speicher, USB 3.1, M.2 Schnittstelle): € 272,16
  • Kingston 4 x D4 8GB 2400-17 Sx8 KVR: € 207,48
  • THERMALRIGHT Lüfter Therma Macho 120 Rev.A: € 40,89
Macht summa summarum: € 1.412,23

Aus NT4 (32bit) wird Server 2016 (64bit)

Was bisher geschah:

  • Virtualisierung der NT4-Maschine (komplett)
  • Erzeugung eines VMware-Clons lokal
  • Deinstallation der VMware-Tools unter NT4 (wichtig!)
  • Upgrade von NT4 auf Server 2000
  • Wichtig: Installation des ServicePacks 4 und Installation des KB835732 (Windows2000-KB835732-x86-DEU.exe), sonst funktionert der folgende Schritt nicht:
  • Installation der VMware-Tools unter Server 2000
  • Installation einer virtuellen XP-Maschine im lokalen (nur VM-Host) Netz des Servers2000 – Zugriffskontrolle, Exchange 5.5 funktioniert nach wie vor
  • Installation eines Servers 2008R2 inkl. Servicepacks (wiederum im lokalen Host-Netz), Integration des Servers in die Domäne des Servers 2000
    Wichtig: Server 2000 muss als DNS-Server fungieren und sich selbst als DNS-Server verwenden – die Domainserver- und Domain-Einträge im DNS müssen vorhanden sein. Server 2008 muss den Server 2000 als DNS-Server verwenden.
  • Am Server 2000 (!) von der Server 2008-CD aus dem Ordner „Support\Adprep“  den Befehl adprep32 /forestprep durchführen
  • Die Domäne am Server 2000 unter „Active Directory-Domänen und Vertrauensstellungen“ – Eigenschaften der aktiven Domäne in den „einheitlichen Modus“ versetzen (war vorher im gemischten NT4/Win2k-Modus).
  • Dann wiederum am Server 2000 von der Server 2008-CD den Befehl adprep32 /domainprep ausführen
  • Am Server 2008 dcpromo.exe ausführen und den Server als zusätzlichen Domänen-Controller im Netz installieren, es wird auch der DNS-Server installiert und konfiguriert.

Jetzt war dann erst mal Pause – diese Infoseite hat mir dann aber beim Heraufstufen des 2008er-Servers zum Haup-Domänencontroller sehr weitergeholfen: https://technikblog.rachfahl.de/losungen/umzug-einer-active-directory-domne-von-einem-small-business-server-2003-zu-einem-windows-server-2012/

Folgende Kommandos (jeweils am neuen Server 2008 durchzuführen) sind für die Übertragung der FSMO-Rollen verantwortlich (sprich, aus dem Backup Domaincontroller wird der Primäre Domaincontroller. Ich zitiere die o.a. Website):

Administrative Eingabeaufforderung öffnen, folgende Befehle eingeben:

  • NTDSUTIL
  • Roles
  • Connections
  • Connect To Server <Servername_des_neuen_Servers>
  • Quit

Jetzt die Übertragung der Rolen starten, Popup-Fenster jeweils mit „Ja“ bestätigen:

  • Transfer Schema Master
  • Transfer Naming master
  • Transfer RID Master
  • Transfer PDC
  • Transfer Infrastructure Master

Danach zweimal QUIT eingeben – fertig.

Anmerkung (habe ich noch nicht kontrolliert): Wenn Sie einem SBS-Server die Rollen wegnehmen, empfindet dieser das als “Verstoß gegen seine Betriebsregeln” und startet nach einer gewissen Zeit in regelmäßigen Abständen neu. Standardmäßig liegt dieser Zeitraum bei 7 Tagen, der Patch KB943494 verlängert diesen Zeitraum auf 21 Tage.

Als nächstes habe ich versucht, nun in der Domäne, in der sowohl ein alter Windows 2000 Server mit Exchange 5.5 und SQL 2000 läuft, mit Windows XP und Windows 10 zu experimentieren, um festzustellen, ob alles nach wie vor funktioniert (würde mir eine Verschnaufpause für die Echt-Umstellung verschaffen). Am XP-Client scheint alles klaglos zu funktionieren, der Windows 10 Client kann sich jetzt auch an der „alten“ Domäne anmelden, was allerdings NICHT funktioniert ist zB Outlook 2010 – das verweigert die Zusammenarbeit mit dem alten Exchange 5.5-Server. Aber auch hier hilft es zwischenzeitlich, Outlook 2003 unter Windows 10 zu installieren – das klappt einwandfrei, auch die Verbindung zum alten Exchange-Server!

 

Autobahnmaut-Abzocke in Slowenien vermeiden

Aktuell (September 2016) werden für die lächerliche Streckenlänge von 45 km fertig ausgebauter Autobahn auf der Route von Spielfeld nach Kroatien für eine 7-Tages-Vignette (Kategorie PKW) 15 Euro fällig. Das alleine wäre ja schon frech, allerdings benötigt man für einen einwöchigen Urlaub im Süden bereits 2 Vignetten (oder eine Monatsvignette), was den Preis auf 2 x 15 bzw. 1 x 30 Euro steigert.
Quelle: pers. Erfahrung und ÖAMTC (Zit: Wichtig für Kurzurlauber: Für einen Urlaub von zum Beispiel Samstag bis Samstag sind 2 7-Tages-Vignetten oder eine 1-Monats-Vignette nötig, da der Zeitraum von Samstag bis Samstag bereits 8 Kalendertage misst.)

Würde man das auf die ebenfalls perfekt ausgebaute Autobahnstrecke von der Slowenisch-Kroatischen Grenze bis z.B. Zadar umlegen käme man bei Hin- und Rückreise auf etwa 212 Euro Maut!

Schon alleine deswegen (also aus Prinzip) und weil die slowenische Regierung bereits seit Jahren den nur 24 km langen Lückenschluss zwischen dem Autobahnende Draženci und dem Grenzübergang Gruškovje „verschleppt“ (derzeit wird allerdings gebaut) haben wir bei unserer letzten Urlaubsreise beschlossen, bei dieser Abzocke nicht mehr mitzumachen und den längeren, aber durchaus gemütlichen und landschaftlich weitaus schöneren Umweg über Mureck in der Steiermark und Ptuj (Pettau, die älteste Stadtgemeinde in Slowenien und die älteste Stadt des ehemaligen Herzogtums Steiermark) zu wählen. Diese Route vor allem deshalb, weil im Netz diverse Berichte über „Mautfallen“ bei der Route durch Marburg existieren, so soll zB bei einem Kreisverkehr kurz vor Marburg, auf den man fast unweigerlich kurz auffahren muss, bereits Mautpflicht herrschen.

Stolperfallen lauern auf dieser Route eigentlich keine, vor allem wenn man mit einem korrekt programmierten Navi (oder Google Maps) unterwegs ist. Man wählt (natürlich mit der Routenoption „Autobahn“ oder „Mautpflichtige Straßen“ vermeiden) einfach Mureck als Ausgangspunkt und eine der kleinen Ortschaften entlang der Hauptverkehrsroute vor dem Grenzübergang (z.B. Podlehnik) als Ziel. In diesem Bereich ist es derzeit allerdings aufgrund der Straßenbauarbeiten etwas kompliziert, auf die Bundesstraße E59 aufzufahren – da sollte man sich kurz vor der Abreise noch auf Google Maps orientieren, ich bin mir nämlich nicht sicher ob bei der Auffahrt auf der neuen Verbindungsstraße Nr. 2 zwischen Ptuj und der E59 nicht bereits (oder demnächst) Vignettenpflicht herrscht. Im Zweifel nach der Drau-Überquerung in Ptuj einfach links abbiegen und auf der „alten“ Bundesstraße Richtung Süden fahren. Ich habe unsere gefahrene Route HIER verlinkt.

mureck-ptuj-kroatien

Why is correct autorouting so difficult, Garmin?

3 examples from a tour in Austria last weekend:

  1. Route from „Langenlois“ to „Nöhagen“:
    green = autoroute by garmin
    orange = simple direct waygarmin-navinonsene-01
  2. Route from „Melk“ to „Wieselburg“
    green = autoroute directing me on a minor road directly near the highway connection!
    note: no „highway“ or „toll road“ avoidance activated in the settings!!!
    orange: simple direct connection to the highway
    garmin-navinonsene-02
  3. Route from center of „Mariazell“ to „Neuberg an der Mürz“
    green = Garmin directing me on a very narrow, steep street in the city instead of leading me on the main road (orange) to the exit of the village
    garmin-navinonsene-03

navigation device: zumo660 (current firmware)
map: city navigator europe 2017.1

Neues Lieblingsmesser: CRKT Ikoma „Fossil“ (Plain Blade Folder)

Unlängst stolperte ich beim Surfen auf der Böker-Homepage über ein Messer in sehr interessantem Look – das „Fossil“ vom Designer Flavio Ikoma, gefertigt von CRKT (Columbia River Knife and Tool). Neugierig geworden bestellte ich es mir gleich beim „grossen Versandhaus“ und wenige Tage später hielt ich das wild aussehende Teil in der Hand. Mittlerweile (und nachdem ich der Klinge einen neuen, feineren Schliff verpasst habe) gefällt es mir immer besser, es liegt extrem gut in der Hand und hat genau die richtige Größe für viele Aufgaben. Einziges Manko: Steckt es mit dem Clip gesichert in der Hosentasche ist es recht unangenehm, die Hand einzustecken – die Oberfläche des Griffmaterials ist doch recht rau.

CRKT Ikoma "Fossil"